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What is Calc?

Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a 
spreadsheet and then manipulate this data to produce certain results.

Alternatively, you can enter data and then use Calc in a ‘What if...’ manner by changing some of 
the data and observing the results without having to retype the entire spreadsheet or sheet.

Other features provided by Calc include:

• Functions, which can be used to create formulas to perform complex calculations on data.

• Database functions, to arrange, store, and filter data.

• Dynamic charts; a wide range of 2D and 3D charts.

• Macros, for recording and executing repetitive tasks; scripting languages supported include
LibreOffice Basic, Python, BeanShell, and JavaScript.

• Ability to open, edit, and save Microsoft Excel spreadsheets.

• Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and 
PostScript.

Note

If you want to use macros written in Microsoft Excel using the VBA macro code in 
LibreOffice, you must first edit the code in the LibreOffice Basic IDE editor. See 
Chapter 13 Getting Started with Macros and Calc Guide Chapter 12 Calc Macros.

Spreadsheets, sheets and cells

Calc works with elements called spreadsheets. Spreadsheets consist of a number of individual
sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by 
its row number and column letter.

Cells hold the individual elements – text, numbers, formulas, and so on – that make up the data to 
display and manipulate.

Each spreadsheet can have several sheets, and each sheet can have several individual cells. In 
Calc, each sheet can have a maximum of 1,048,576 rows (65,536 rows in Calc 3.2 and earlier) and 
a maximum of 1024 columns.

Calc main dialog

When Calc is started, the main window opens (Figure 89) and the various parts of this dialog are 
explained below.

Title bar

The Title bar, located at the top, shows the name of the current spreadsheet. When the 
spreadsheet is newly created, its name is Untitled X, where X is a number. When you save a 
spreadsheet for the first time, you are prompted to enter a name of your choice.

Menu bar

The Menu bar is where you select one of the menus and various sub-menus appear giving you 
more options. You can also customize the Menu bar; see Chapter 14 Customizing LibreOffice for 
more information.

112 | Getting Started with LibreOffice 4.0



Figure 89: Calc main dialog

• File – contains commands that apply to the entire document; for example Open, Save, 
Wizards, Export as PDF, Print, Digital Signatures and so on.

• Edit – contains commands for editing the document; for example Undo, Copy, Changes, 
Fill, Plug-in and so on.

• View – contains commands for modifying how the Calc user interface looks; for example 
Toolbars, Column & Row Headers, Full Screen, Zoom and so on.

• Insert – contains commands for inserting elements into a spreadsheet; for example Cells, 
Rows, Columns, Sheets, Picture and so on.

• Format – contains commands for modifying the layout of a spreadsheet; for example Cells,
Page, Styles and Formatting, Alignment and so on.

• Tools – contains various functions to help you check and customize your spreadsheet, for 
example Spelling, Share Document, Gallery, Macros and so on.

• Data – contains commands for manipulating data in your spreadsheet; for example Define 
Range, Sort, Consolidate and so on.

• Window – contains commands for the display window; for example New Window, Split and 
so on.

• Help – contains links to the help system included with the software and other 
miscellaneous functions; for example Help, License Information, Check for Updates and so 
on.

Toolbars

The default setting when Calc opens is for the Standard and Formatting toolbars to be docked at 
the top of the workspace (Figure 89).
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Calc toolbars can be either docked and fixed in place, or floating allowing you to move a toolbar 
into a more convenient position on your workspace. Docked toolbars can be undocked and moved 
to different docked position on the workspace or undocked to become a floating toolbar. Toolbars 
that are floating when opened can be docked into a fixed position on your workspace.

The default set of icons (sometimes called buttons) on toolbars provide a wide range of common 
commands and functions. You can also remove or add icons to toolbars, see Chapter 14 
Customizing LibreOffice for more information.

Formula bar

The Formula Bar is located at the top of the sheet in your Calc workspace. The Formula Bar is 
permanently docked in this position and cannot be used as a floating toolbar. If the Formula Bar is 
not visible, go to View on the main menu bar and select Formula Bar.

Figure 90: Formula bar

Going from left to right and referring to Figure 90, the Formula Bar consists of the following:

• Name Box – gives the cell reference using a combination of a letter and number, for 
example A1. The letter indicates the column and the number indicates the row of the 
selected cell.

• Function Wizard  – opens a dialog from which you can search through a list of 
available functions. This can be very useful because it also shows how the functions are 
formatted.

• Sum  – clicking on the Sum icon totals the numbers in the cells above the selected cell 
and then places the total in the selected cell. If there are no numbers above the selected 
cell, then the cells to the left are totaled.

• Function  – clicking on the Function icon inserts an equals (=) sign into the selected cell 
and the Input line allowing a formula to be entered.

• Input line – displays the contents of the selected cell (data, formula, or function) and 
allows you to edit the cell contents.

• You can also edit the contents of a cell directly in the cell itself by double clicking on the 
cell. When you enter new data into a cell, the Sum and Function icons change to Cancel 

and Accept icons .

Note

In a spreadsheet the term function covers much more than just mathematical 
functions. See the Calc Guide Chapter 7 Using Formulas and Functions in for more 
information.

Spreadsheet layout

Individual cells

The main section of the workspace in Calc displays the cells in the form of a grid. Each cell is 
formed by the intersection of the columns and rows in the spreadsheet.

At the top of the columns and the left end of the rows are a series of header boxes containing 
letters and numbers. The column headers use an alpha character starting at A and go on to the 
right. The row headers use a numerical character starting at 1 and go down.
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These column and row headers form the cell references that appear in the Name Box on the 
Formula Bar (Figure 90). If the headers are not visible on your spreadsheet, go to View on the 
main menu bar and select Column & Row Headers.

Sheet tabs

In Calc you can have more than one sheet in a spreadsheet. At the bottom of the grid of cells in a 
spreadsheet are sheet tabs indicating how many sheets there are in your spreadsheet. Clicking on 
a tab enables access to each individual sheet and displays that sheet. An active sheet is indicated 
with a white tab (default Calc setup). You can also select multiple sheet by holding down the Ctrl 
key while you click on the sheet tabs.

To change the default name for a sheet (Sheet1, Sheet2, and so on), right click on a sheet tab and 
select Rename Sheet from the context menu. A dialog opens allowing you to type in a new name 
for the sheet. Click OK when finished to close the dialog.

To change the color of a sheet tab, right click on the tab and select Tab Color from the context 
menu to open the Tab Color dialog (Figure 91). Select your color and click OK when finished to 
close the dialog. To add new colors to this color palette, see Chapter 14 Customizing LibreOffice 
for more information.

Figure 91: Tab color dialog

Figure 92: Calc status bar
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Status bar

The Calc status bar (Figure 92) provides information about the spreadsheet and convenient ways 
to quickly change some of its features. Most of the fields are similar to those in other components 
of LibreOffice; see Chapter 1 Introducing LibreOffice in this guide and the Calc Guide Chapter 1 
Introducing Calc for more information.

Opening a CSV file

Comma-separated-values (CSV) files are spreadsheet files in a text format where cell contents are 
separated by a character, for example comma, semi-colon, and so on. Each line in a CSV text file 
represents a row in a spreadsheet. Text is entered between quotation marks; numbers are entered 
without quotation marks.

To open a CSV file in Calc:

1) Choose File > Open on the main menu bar and locate the CSV file that you want to open.

2) Select the file and click Open. By default, a CSV file has the extension .csv. However, 

some CSV files may have a .txt extension.

3) The Text Import dialog (Figure 93) opens allowing you to select the various options 
available when importing a CSV file into a Calc spreadsheet.

4) Click OK to open and import the file.

Figure 93: Text Import dialog
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The various options for importing CSV files into a Calc spreadsheet are as follows:

• Import

– Character Set – specifies the character set to be used in the imported file.

– Language – determines how the number strings are imported.

If Language is set to Default for CSV import, Calc will use the globally set language. If 
Language is set to a specific language, that language will be used when importing 
numbers.

– From Row – specifies the row where you want to start the import. The rows are visible 
in the preview window at the bottom of the dialog.

• Separator Options – specifies whether your data uses separators or fixed widths as 
delimiters.

– Fixed width – separates fixed-width data (equal number of characters) into columns. 
Click on the ruler in the preview window to set the width.

– Separated by – select the separator used in your data to delimit the data into columns. 
When you select Other, you specify the character used to separate data into columns. 
This custom separator must also be contained in your data.

– Merge delimiters – combines consecutive delimiters and removes blank data fields.

– Text delimiter – select a character to delimit text data.

• Other options

– Quoted fields as text – when this option is enabled, fields or cells whose values are 
quoted in their entirety (the first and last characters of the value equal the text delimiter) 
are imported as text.

– Detect special numbers – when this option is enabled, Calc will automatically detect all 
number formats, including special number formats such as dates, time, and scientific 
notation.

The selected language also influences how such special numbers are detected, since 
different languages and regions many have different conventions for such special 
numbers.

When this option is disabled, Calc will detect and convert only decimal numbers. The 
rest, including numbers formatted in scientific notation, will be imported as text. A 
decimal number string can have digits 0-9, thousands separators, and a decimal 
separator. Thousands separators and decimal separators may vary with the selected 
language and region.

• Fields – shows how your data will look when it is separated into columns.

– Column type – select a column in the preview window and select the data type to be 
applied to the imported data.

– Standard – Calc determines the type of data.

– Text – imported data are treated as text.

– US English – numbers formatted in US English are searched for and included 
regardless of the system language. A number format is not applied. If there are no US 
English entries, the Standard format is applied.

– Hide – the data in the column are not imported.
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Saving spreadsheets

To save a spreadsheet, see Chapter 1 Introducing LibreOffice for more details on how to save files 
manually or automatically. Calc can also save spreadsheets in a range of formats and also export 
spreadsheets to PDF, HTML and XHTML file formats, see the Calc Guide Chapter 6 Printing, 
Exporting, and E-mailing for more information.

Saving in other spreadsheet formats

If you need to exchange files with users who are unable to receive spreadsheet files in Open 
Document Format (ODF) (*.ods), which Calc uses as default format, you can save a spreadsheet 

in an another format.

1) Save your spreadsheet in Calc spreadsheet file format (*.ods).

2) Select File > Save As on the main menu bar to open the Save As dialog (Figure 94).

3) In File name, if you wish, enter a new file name for the spreadsheet.

4) In File type drop-down menu, select the type of spreadsheet format you want to use.

5) If Automatic file name extension is selected, the correct file extension for the 
spreadsheet format you have selected will be added to the file name.

6) Click Save.

7) Each time you click Save, the Confirm File Format dialog opens (Figure 95). Click Use 

[xxx] Format to continue saving in your selected spreadsheet format or click Use ODF 

Format to save the spreadsheet in Calc ODS format.

8) If you select Text CSV format (*.csv) for your spreadsheet, the Export Text File dialog 

(Figure 96) opens allowing you to select the character set, field delimiter, text delimiter and 
so on to be used for your CSV file.

Figure 94: Save As dialog
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Figure 95: Confirm File Format dialog

Figure 96: Export Text File dialog for CSV files

Tip

To have Calc save documents by default in a file format other than the default ODF 
format, go to Tools > Options > Load/Save > General. In Default file format and 
ODF settings > Document type, select Spreadsheet, then in Always save as, 
select your preferred file format.

Navigating within spreadsheets

Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You 
can generally use the method you prefer.

Cell navigation

When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is 
selected, the cell area is colored. The color of the cell border emphasis and the color of a group of 
selected cells depends on the operating system being used and how you have set up LibreOffice.

• Using the mouse – place the mouse pointer over the cell and click the left mouse button. 
To move the focus to another cell using the mouse, simply move the mouse pointer to the 
cell where you want the focus to be and click the left mouse button.

• Using a cell reference – highlight or delete the existing cell reference in the Name Box on 
the Formula Bar (Figure 90 on page 114). Type the new cell reference of the cell you want 
to move to and press Enter key. Cell references are case insensitive: for example, typing 
a3 or A3 will move the focus to cell A3.
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Figure 97: Navigator dialog in Calc

• Using the Navigator – click on the Navigator icon  on the Standard toolbar or press 

the F5 key to open the Navigator dialog (Figure 97). Type the cell reference into the 

Column and Row fields and press the Enter key.

• Using the Enter key – pressing Enter moves the cell focus down in a column to the next 
row. Pressing Shift+Enter moves the focus up in a column to the next row.

• Using the Tab key – pressing Tab moves the cell focus right in a row to the next column. 
Pressing Shift+Tab moves the focus to the left in a row to the next column.

• Using the arrow keys – pressing the arrow keys on the keyboard moves the cell focus in 
the direction of the arrow pressed.

• Using Home, End, Page Up and Page Down

– Home moves the cell focus to the start of a row.

– End moves the cell focus to the last cell on the right in the row that contains data.

– Page Down moves the cell focus down one complete screen display.

– Page Up moves the cell focus up one complete screen display.

Sheet navigation

Each sheet in a spreadsheet is independent of the other sheets, though references can be linked 
from one sheet to another. There are three ways to navigate between different sheets in a 
spreadsheet.

• Using the Navigator – when the Navigator is open (Figure 97), double-clicking on any of 
the listed sheets selects the sheet.

• Using the keyboard – using key combinations Ctrl+Page Down moves one sheet to the 
right and Ctrl+Page Up moves one sheet to the left.

• Using the mouse – clicking on one of the sheet tabs at the bottom of the spreadsheet 
selects that sheet.

If there are a lot of sheets in your spreadsheet, then some of the sheet tabs may be hidden behind 
the horizontal scroll bar at the bottom of the screen. If this is the case, using the four buttons to the 
left of the sheet tabs can move the tabs into view (Figure 98).
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Note
The sheet tab arrows that appear in Figure 98 are only active if there are sheet 
tabs that cannot be seen.

Note

When you insert a new sheet into your spreadsheet, Calc automatically uses the 
next number in the numeric sequence as a name. Depending on which sheet is 
open when you insert a new sheet, your new sheet may not be in numerical order. 
It is recommended to rename sheets in your spreadsheet to make them more 
recognizable.

Figure 98. Navigating sheet tabs

Keyboard navigation

Pressing a key or a combination of keys allows you to navigate a spreadsheet using the keyboard. 
A key combination is where you press more than one key together, for example Ctrl+Home key 
combination to move to cell A1. Table 4 lists the keys and key combinations you can use for 
spreadsheet navigation in Calc.

Table 4. Keyboard cell navigation

Keyboard 
shortcut

Cell navigation

→ Moves cell focus right one cell

← Moves cell focus left one cell

↑ Moves cell focus up one cell

↓ Moves cell focus down one cell

Ctrl+→ Moves cell focus to the first column on the right containing data in that row if 
cell focus is on a blank cell.

Moves cell focus to the last column on the right containing data in that row if 
cell focus is on a cell containing data.

Moves cell focus to the last column on the right in the spreadsheet if there are 
no more cells containing data.

Ctrl+← Moves cell focus to the last column on the left containing data in that row if 
cell focus is on a blank cell.

Moves cell focus to the first column on the left containing data in the 
spreadsheet if cell focus is on a cell containing data.

Moves cell focus to the first column in that row if there are no more cells 
containing data.
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Keyboard 
shortcut

Cell navigation

Ctrl+↑ Moves cell focus from a blank cell to the first cell above containing data in the 
same column.

Moves cell focus from a cell containing data to the cell in Row 1 in the same 
column.

Ctrl+↓ Moves cell focus from a blank cell to the first cell below containing data in the 
same column.

Moves cell focus from a cell containing data to the last cell containing data in 
the same column.

Moves cell focus from the last cell containing data to the cell in the same 
column in the last row of the spreadsheet.

Ctrl+Home Moves cell focus from anywhere on the spreadsheet to Cell A1 on the same 
sheet.

Ctrl+End Moves cell focus from anywhere on the spreadsheet to the last cell in the 
lower right-hand corner of the rectangular area of cells containing data on the 
same sheet.

Alt+Page Down Moves cell focus one screen to the right (if possible).

Alt+Page Up Moves cell focus one screen to the left (if possible).

Ctrl+Page Down Moves cell focus to the same cell on the next sheet to the right in sheet tabs if 
the spreadsheet has more than on sheet.

Ctrl+Page Up Moves cell focus to the same cell on the next sheet to the left in sheet tabs if 
the spreadsheet has more than on sheet.

Tab Moves cell focus to the next cell on the right

Shift+Tab Moves cell focus to the next cell on the left

Enter Down one cell (unless changed by user)

Shift+Enter Up one cell (unless changed by user)

Customizing the Enter key

You can choose the direction in which the Enter key moves the cell focus by going to Tools > 

Options > LibreOffice Calc > General. Select the direction cell focus moves from the drop-down 
list. Depending on the file being used or the type of data being entered, setting a different direction 
can be useful. The Enter key can also be used to switch into and out of editing mode. Use the first 
two options under Input settings in Figure 99 to change the Enter key settings.

Figure 99: Customizing the Enter key
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Selecting items in a spreadsheet

Selecting cells

Single cell

Left-click in the cell. You can verify your selection by looking in the Name Box on the Formula Bar 
(Figure 90 on page 114).

Range of contiguous cells

A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse cursor:

1) Click in a cell.

2) Press and hold down the left mouse button.

3) Move the mouse around the screen.

4) Once the desired block of cells is highlighted, release the left mouse button.

To select a range of cells without dragging the mouse:

1) Click in the cell which is to be one corner of the range of cells.

2) Move the mouse to the opposite corner of the range of cells.

3) Hold down the Shift key and click.

Tip

You can also select a contiguous range of cells by first clicking in the Selection 

mode field on the Status Bar (Figure 92 on page 115) and selecting Extending 

selection before clicking in the opposite corner of the range of cells. Make sure to 
change back to Standard selection or you may find yourself extending a cell 
selection unintentionally.

To select a range of cells without using the mouse:

1) Select the cell that will be one of the corners in the range of cells.

2) While holding down the Shift key, use the cursor arrows to select the rest of the range.

Tip

You can also directly select a range of cells using the Name Box. Click into the 
Name Box on the Formula Bar (Figure 90 on page 114). To select a range of cells, 
enter the cell reference for the upper left-hand cell, followed by a colon (:), and 
then the lower right-hand cell reference. For example, to select the range that 
would go from A3 to C6, you would enter A3:C6.

Range of non-contiguous cells

1) Select the cell or range of cells using one of the methods above.

2) Move the mouse pointer to the start of the next range or single cell.

3) Hold down the Ctrl key and click or click-and-drag to select another range of cells to add to 
the first range.

4) Repeat as necessary.

Chapter 5  Getting Started with Calc | 123



Selecting columns and rows

Single column or row

To select a single column, click on the column header (Figure 89 on page 113).

To select a single row, click on the row header.

Multiple columns or rows

To select multiple columns or rows that are contiguous:

1) Click on the first column or row in the group.

2) Hold down the Shift key.

3) Click the last column or row in the group.

To select multiple columns or rows that are not contiguous:

1) Click on the first column or row in the group.

2) Hold down the Ctrl key.

3) Click on all of the subsequent columns or rows while holding down the Ctrl key.

Entire sheet

To select the entire sheet, click on the small box between the column headers and the row headers 
(Figure 100), or use the key combination Ctrl+A to select the entire sheet, or go to Edit on the 
main menu bar and select Select All.

Figure 100. Select All box

Selecting sheets

You can select either one or multiple sheets in Calc. It can be advantageous to select multiple 
sheets, especially when you want to make changes to many sheets at once.

Single sheet

Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes 
white (default Calc setup).

Multiple contiguous sheets

To select multiple contiguous sheets:

1) Click on the sheet tab for the first desired sheet.

2) Move the mouse pointer over the sheet tab for the last desired sheet.

3) Hold down the Shift key and click on the sheet tab.

4) All tabs between these two selections will turn white (default Calc setup). Any actions that 
you perform will now affect all highlighted sheets.
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Multiple non-contiguous sheets

To select multiple non-contiguous sheets:

1) Click on the sheet tab for the first desired sheet.

2) Move the mouse pointer over the sheet tab for the second desired sheet.

3) Hold down the Ctrl key and click on the sheet tab.

4) Repeat as necessary.

5) The selected tabs will turn white (default Calc setup). Any actions that you perform will now 
affect all highlighted sheets.

All sheets

Right-click a sheet tab and choose Select All Sheets from the context menu.

Working with columns and rows

Inserting columns and rows

Note

When you insert a column, it is inserted to the left of the highlighted column. When 
you insert a row, it is inserted above the highlighted row.

When you insert columns or rows, the cells take the formatting of the 
corresponding cells in the next column to left or the row above.

Single column or row

Using the Insert menu:

1) Select a cell, column, or row where you want the new column or row inserted.

2) Go to Insert on the main menu bar and select either Insert > Columns or Insert > Rows.

Using the mouse:

1) Select a column or row where you want the new column or row inserted.

2) Right-click the column or row header.

3) Select Insert Columns or Insert Rows from the context menu.

Multiple columns or rows

Multiple columns or rows can be inserted at once rather than inserting them one at a time.

1) Highlight the required number of columns or rows by holding down the left mouse button on 
the first one and then dragging across the required number of identifiers.

2) Proceed as for inserting a single column or row above.

Deleting columns and rows

Single column or row

To delete a single column or row:

1) Select a cell in the column or row you want to delete,.

2) Go to Edit on the main menu bar and select Delete Cells or right click and select Delete 
from the context menu.
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3) Select the option you require from the Delete Cells dialog (Figure 101).

Figure 101: Delete Cells dialog

Alternatively:

1) Click in the column or header to select the column or row.

2) Go to Edit on the main menu bar and select Delete Cells or right click and select Delete 

Columns or Delete Rows from the context menu.

Multiple columns or rows

To delete multiple columns or rows:

1) Select the columns or rows, see “Multiple columns or rows” on page 124 for more 
information.

2) Go to Edit on the main menu bar and select Delete Cells or right click and select Delete 

Columns or Delete Rows from the context menu.

Working with sheets

Inserting new sheets

Click on the Add Sheet icon . This inserts a new sheet after the last sheet in the spreadsheet 
without opening the Insert Sheet dialog. The following methods open the Insert Sheet dialog 
(Figure 102) where you can position the new sheet, create more than one sheet, name the new 
sheet, or select a sheet from a file.

Figure 102: Insert Sheet dialog
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• Select the sheet where you want to insert a new sheet, then go to Insert > Sheet on the 
main menu bar.

• Right-click on the sheet tab where you want to insert a new sheet and select Insert Sheet 
from the context menu.

• Click in the empty space at the end of the sheet tabs.

• Right-click in the empty space at the end of the sheet tabs and select Insert Sheet from 
the context menu.

Moving and copying sheets

You can move or copy sheets within the same spreadsheet by dragging and dropping or using the 
Move/Copy Sheet dialog. To move or copy a sheet into a different spreadsheet; you have to use 
the Move/Copy Sheet dialog.

Dragging and dropping

To move a sheet to a different position within the same spreadsheet, click on the sheet tab and 
drag it to its new position before releasing the mouse button.

To copy a sheet within the same spreadsheet, hold down the Ctrl key (Option key on Mac) then 
click on the sheet tab and drag it to its new position before releasing the mouse button. The mouse 
pointer may change to include a plus sign depending on the setup of your operating system.

Using a dialog

The Move/Copy Sheet dialog (Figure 103) allows you to specify exactly whether you want the 
sheet in the same or a different spreadsheet, its position within the spreadsheet, the sheet name 
when you move or copy the sheet.

Figure 103: Move/Copy Sheet dialog

Chapter 5  Getting Started with Calc | 127



1) In the current document, right-click on the sheet tab you wish to move or copy and select 
Move/Copy Sheet from the context menu or go to Edit > Sheet > Move/Copy on the main 
menu bar.

2) Select Move to move the sheet or Copy to copy the sheet.

3) Select the spreadsheet where you want the sheet to be placed from the drop-down list in 
To document. This can be the same spreadsheet, another spreadsheet already open, or 
you can create a new spreadsheet.

4) Select the position in Insert before where you want to place the sheet.

5) Type a name in the New name text box if you want to rename the sheet when it is moved 
or copied. If you do not enter a name, Calc creates a default name (Sheet 1, Sheet 2, and 
so on).

6) Click OK to confirm the move or copy and close the dialog.

Caution
When you move or copy to another spreadsheet or a new spreadsheet, a conflict 
may occur with formulae linked to other sheets in the previous location.

Deleting sheets

To delete a single sheet, right-click on the sheet tab you want to delete and select Delete Sheet 
from the context menu, or go to Edit > Sheet > Delete from on the main menu bar. Click Yes to 
confirm the deletion.

To delete multiple sheets, select the sheets (see “Selecting sheets” on page 124), then right-click 
one of the sheet tabs and select Delete Sheet from the context menu, or go to Edit > Sheet > 

Delete from on the main menu bar. Click Yes to confirm the deletion.

Renaming sheets

By default, the name for each new sheet added is SheetX, where X is the number of the next sheet 

to be added. While this works for a small spreadsheet with only a few sheets, it can become 
difficult to identify sheets when a spreadsheet contains many sheets..

You can rename a sheet using one of the following methods:

• Enter the name in the Name text box when you create the sheet using the Insert Sheet 
dialog (Figure 102 on page 126).

• Right-click on a sheet tab and select Rename Sheet from the context menu to replace the 
existing name with a different one.

• Double-click on a sheet tab to open the Rename Sheet dialog.

Note

Sheet names must start with either a letter or a number; other characters including 
spaces are not allowed. Apart from the first character of the sheet name, permitted
characters are letters, numbers, spaces, and the underscore character. Attempting 
to rename a sheet with an invalid name will produce an error message.
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Viewing Calc

Changing document view

Use the zoom function to show more or fewer cells in the window when you are working on a 
spreadsheet. For more about zoom, see Chapter 1 Introducing LibreOffice in this guide.

Freezing rows and columns

Freezing locks a number of rows at the top of a spreadsheet or a number of columns on the left of 

a spreadsheet or both rows and columns. Then, when moving around within a sheet, the cells in 
frozen rows and columns always remain in view.

Figure 104 shows some frozen rows and columns. The heavier horizontal line between rows 3 and 

23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and columns A 
to F are frozen. The rows between 3 and 23 and the columns between F and Q have been scrolled 
off the page.

Figure 104. Frozen rows and columns

Freezing rows or columns

1) Click on the row header below the rows you want the freeze or click on the column header 
to the right of the columns where you want the freeze.

2) Go to Window on the main menu bar and select Freeze. A heavier line appears between 
the rows or columns indicating where the freeze has been placed.

Freezing rows and columns

1) Click into the cell that is immediately below the rows you want frozen and immediately to 
the right of the columns you want frozen.

2) Go to Window on the main menu bar and select Freeze. A heavier line appears between 
the rows or columns indicating where the freeze has been placed.

Unfreezing

To unfreeze rows or columns, go to Window on the main menu bar and uncheck Freeze. The 
heavier lines indicating freezing will disappear.

Splitting the screen

Another way to change the view is by splitting the screen your spreadsheet is displayed in (also 

known as splitting the window). The screen can be split horizontally, vertically, or both, giving you 

up to four portions of the spreadsheet in view at any one time. An example of splitting the screen is 
shown in Figure 105 where a split is indicated by a black line.

Why would you want to do this? For example, a large spreadsheet in which one cell has a number 
in it that is used by three formulas in other cells. Using the split-screen technique, you can position 
the cell containing the number in one section and each of the cells with formulas in the other 
sections. This allows you to change the number in one cell and watch how it affects each of the 
formulas.
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Splitting horizontally or vertically

1) Click on the row header below the rows where you want to split the screen horizontally or 
click on the column header to the right of the columns where you want to split the screen 
vertically.

2) Go to Window on the main menu bar and select Split. A heavy black line appears between 
the rows or columns indicating where the split has been placed.

Alternatively for a horizontal split, click on the thick black line at the top of the vertical scroll bar 
(Figure 106) and drag the split line below the row where you want the horizontal split positioned.

Alternatively for a vertical split, click on the thick black line at the right of the horizontal scroll bar 
(Figure 106) and drag the split line to the right of the column where you want the vertical split 
positioned.

Figure 105. Split screen example

Figure 106. Split screen bars

Splitting horizontally and vertically

1) Click into the cell that is immediately below the rows where you want to split the screen 
horizontally and immediately to the right of the columns where you want to split the screen 
vertically.

2) Go to Window on the main menu bar and select Split. A heavy black line appears between 
the rows or columns indicating where the split has been placed.

Removing split views

To remove a split view, do any of the following:

• Double-click on each split line.

• Click on and drag the split lines back to their places at the ends of the scroll bars.

• Go to Window on the main menu bar and uncheck Split.
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Using the keyboard

Most data entry in Calc can be accomplished using the keyboard.

Numbers

Click in the cell and type in a number using the number keys on either the main keyboard or 
numeric keypad. By default, numbers are right aligned in a cell.

Minus numbers

To enter a negative number, either type a minus (–) sign in front of the number or enclose the 
number in parentheses (), for example (1234). The result for both methods of entry will be the 
same, for example -1234.

Leading zeroes

To retain a minimum number of characters in a cell when entering numbers and retain the number 
format, for example 1234 and 0012, leading zeroes have to be added as follows:

1) With the cell selected, right click on the cell select Format Cells from the context menu or 
go to Format > Cells on the main menu bar or use the keyboard shortcut Ctrl+1 to open 
the Format Cells dialog (Figure 107).

2) Make sure the Numbers page is selected then select Number in the Category list.

3) In Options > Leading Zeros, enter the minimum number of characters required. For 
example, for four characters, enter 4. Any number less than four characters will have 
leading zeroes added, for example 12 becomes 0012.

4) Click OK. The number entered retains its number format and any formula used in the 
spreadsheet will treat the entry as a number in formula functions.

Figure 107: Format Cells dialog – Numbers page

If a number is entered with leading zeroes, for example 01481, by default Calc will automatically 
drop the leading 0. To preserve leading zeroes in a number:

1) Type an apostrophe (') before the number, for example '01481.

2) Move the cell focus to another cell. The apostrophe is automatically removed, the leading 
zeroes are retained and the number is converted to text left aligned.
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Numbers as text

Numbers can also be converted to text as follows:

1) With the cell selected, right click on the cell select Format Cells from the context menu or 
go to Format > Cells on the main menu bar or use the keyboard shortcut Ctrl+1 to open 
the Format Cells dialog (Figure 107).

2) Make sure the Numbers page is selected, then select Text from the Category list.

3) Click OK and the number is converted to text and, by default, left aligned.

Note

Any numbers that have been formatted as text in a spreadsheet will be treated as 
a zero by any formulas used in the spreadsheet. Formula functions will ignore text 
entries.

Text

Click in the cell and type the text. By default, text is left-aligned in a cell.

Date and time

Select the cell and type the date or time.

You can separate the date elements with a slash (/) or a hyphen (–) or use text, for example 10 Oct
2012. The date format automatically changes to the selected format used by Calc.

When entering a time, separate time elements with colons, for example 10:43:45. The time format 
automatically changes to the selected format used by Calc.

To change the date or time format used by Calc:

1) With the cell selected, right click on the cell select Format Cells from the context menu or 
go to Format > Cells on the main menu bar or use the keyboard shortcut Ctrl+1 to open 
the Format Cells dialog (Figure 107).

2) Make sure the Numbers page is selected, then select Date or Time from the Category list.

3) Select the date or time format you want to use from the Format list.

4) Click OK.

Autocorrection options

Calc automatically applies many changes during data input using autocorrection, unless you have 
deactivated any autocorrect changes. You can also undo any autocorrection changes by using the 
keyboard shortcut Ctrl+Z or manually by going back to the change and replacing the autocorrection 
with what you want to actually see.

To change the autocorrect options, go to Tools > AutoCorrect Options on the main menu bar to 
open the AutoCorrect dialog (Figure 108).

Replace

Edits the replacement table for automatically correcting or replacing words or abbreviations in your 
document.

Exceptions

Specify the abbreviations or letter combinations that you do not want LibreOffice to correct 
automatically.
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Figure 108: AutoCorrect dialog

Options

Select the options for automatically correcting errors as you type and then click OK.

Localized options

Specify the AutoCorrect options for quotation marks and for options that are specific to the 
language of the text.

Reset

Resets modified values back to the LibreOffice default values.

Deactivating automatic changes

Some AutoCorrect settings are applied when you press the spacebar after you enter data. To turn 
off or on Calc AutoCorrect, go to Tools > Cell Contents on the main menu bar and deselect or 
select AutoInput.

Speeding up data entry

Entering data into a spreadsheet can be very labor-intensive, but Calc provides several tools for 
removing some of the drudgery from input.

The most basic ability is to drop and drag the contents of one cell to another with a mouse. Many 
people also find AutoInput helpful. Calc also includes several other tools for automating input, 
especially of repetitive material. They include the fill tool, selection lists, and the ability to input 
information into multiple sheets of the same document.
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Using the Fill tool

The Calc Fill tool is used to duplicate existing content or create a series in a range of cells in your 
spreadsheet (Figure 109).

1) Select the cell containing the contents you want to copy or start the series from.

2) Drag the mouse in any direction or hold down the Shift key and click in the last cell you 
want to fill.

3) Go to Edit > Fill on the main menu bar and select the direction in which you want to copy 
or create data (Up, Down, Left or Right) or Series from the context menu.

Alternatively, you can use a shortcut to fill cells.

1) Select the cell containing the contents you want to copy or start the series from.

2) Move the cursor over the small square in the bottom right corner of the selected cell. The 
cursor will change shape.

3) Click and drag in the direction you want the cells to be filled. If the original cell contained 
text, then the text will automatically be copied. If the original cell contained a number, a 
series will be created.

Figure 109: Using the Fill tool

Figure 110: Fill Series dialog

Using a fill series

When you select a series fill from Edit > Fill > Series, the Fill Series dialog (Figure 110) opens 
allowing you to select the type of series you want.

• Direction – determines the direction of series creation.

– Down – creates a downward series in the selected cell range for the column using the 
defined increment to the end value.
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– Right – creates a series running from left to right within the selected cell range using the 
defined increment to the end value.

– Up – creates an upward series in the cell range of the column using the defined 
increment to the end value.

– Left – creates a series running from right to left in the selected cell range using the 
defined increment to the end value.

• Series Type – defines the series type.

– Linear – creates a linear number series using the defined increment and end value.

– Growth – creates a growth series using the defined increment and end value.

– Date – creates a date series using the defined increment and end date.

– AutoFill – forms a series directly in the sheet. The AutoFill function takes account of 
customized lists. For example, by entering January in the first cell, the series is 
completed using the list defined in LibreOffice > Tools > Options > LibreOffice Calc 

> Sort Lists. AutoFill tries to complete a value series by using a defined pattern. For 
example, a numerical series using 1,3,5 is automatically completed with 7,9,11,13; a 
date and time series using 01.01.99 and 15.01.99, an interval of fourteen days is used.

• Unit of Time – in this area you specify the desired unit of time. This area is only active if 
the Date option has been chosen in the Series type area.

– Day – use the Date series type and this option to create a series using seven days.

– Weekday – use the Date series type and this option to create a series of five day sets.

– Month – use the Date series type and this option to form a series from the names or 
abbreviations of the months.

– Year – use the Date series type and this option to create a series of years.

• Start Value – determines the start value for the series. Use numbers, dates or times.

• End Value – determines the end value for the series. Use numbers, dates or times.

• Increment – determines the value by which the series of the selected type increases by 
each step. Entries can only be made if the linear, growth or date series types have been 
selected.

Figure 111: Sort Lists dialog
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Defining a fill series

To define your own fill series:

1) Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort Lists dialog 
(Figure 111). This dialog shows the previously-defined series in the Lists box on the left and 
the contents of the highlighted list in the Entries box.

2) Click New and the Entries box is cleared.

3) Type the series for the new list in the Entries box (one entry per line).

4) Click Add and the new list will now appear in the Lists box.

5) Click OK to save the new list.

Using selection lists

Selection lists are available only for text and are limited to using only text that has already been 
entered in the same column.

1) Select a blank cell in a column that contains cells with text entries.

2) Right click and select Selection Lists from the context menu. A drop-down list appears 
listing any cell in the same column that either has at least one text character or whose 
format is defined as text.

3) Click on the text entry you require and it is entered into the selected cell.

Sharing content between sheets

You might want to enter the same information in the same cell on multiple sheets, for example to 
set up standard listings for a group of individuals or organizations. Instead of entering the list on 
each sheet individually, you can enter the information in several sheets at the same time.

Figure 112: Select Sheets dialog

1) Go to Edit > Sheet > Select on the main menu bar to open the Select Sheets dialog 
(Figure 112).

2) Select the individual sheets where you want the information to be repeated.

3) Click OK to select the sheets and the sheet tabs will change color.

4) Enter the information in the cells on the sheet where you want the information to first 
appear and the information will repeated in the selected sheets.

Caution
This technique automatically overwrites, without any warning, any information that 
is already in the cells on the selected sheets. Make sure you deselect the 
additional sheets when you are finished entering information that is going to be 
repeated before continuing entering data into your spreadsheet.
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Validating cell contents

When creating spreadsheets for other people to use, validating cell contents makes sure they enter 
data that is valid or appropriate for the cell. You can also use validation in your own work as a 
guide to entering data that is either complex or rarely used.

Fill series and selection lists can handle some types of data, but are limited to predefined 
information. To validate new data entered by a user, select a cell and go to Data > Validity on the 
main menu bar to define the type of contents that can be entered in that cell. For example, a cell 
may require a date or a whole number with no alphabetic characters or decimal points, or a cell 
may not be left empty.

Depending on how validation is set up, validation can also define the range of contents that can be 
entered, provide help messages explaining the content rules set up for the cell and what users 
should do when they enter invalid content. You can also set the cell to refuse invalid content, 
accept it with a warning, or start a macro when an error is entered. See the Calc Guide Chapter 2 
Entering, Editing and Formatting Data for more information on validating cell contents.

Editing data

Deleting data

Deleting data only

Data can be deleted from a cell without deleting any of the cell formatting. Click in the cell to select 
it and then press the Delete key.

Deleting data and formatting

Data and cell formatting can be deleted from a cell at the same time.

1) Click in the cell to select it.

2) Press the Backspace key, or right-click in the cell and select Delete Contents from the 
context menu, or go to Edit > Delete Contents) on the main menu bar to open the Delete 

Contents dialog (Figure 113). This dialog allows you to delete the different aspects of the 
data in the cell or to delete everything in the cell.

Figure 113: Delete Contents dialog
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Replacing data

To completely replace data in a cell and insert new data, select the cell and type in the new data. 
The new data will replace the data already contained in the cell and will retain the original 
formatting used in the cell.

Alternatively, click in the Input Line on the Formula Bar (Figure 90 on page 114) then double click 
on the data to highlight it completely and type the new data.

Editing data

Sometimes it is necessary to edit the contents of cell without removing all of the data from the cell. 
For example, changing the phrase “Sales in Qtr. 2”  to “Sales rose in Qtr” can be done as follows.

Using the keyboard

1) Click in the cell to select it.

2) Press the F2 key and the cursor is placed at the end of the cell.

3) Use the keyboard arrow keys to reposition the cursor where you want to start entering the 
new data in the cell.

4) When you have finished, press the Enter key and your editing changes are saved.

Using the mouse

1) Double-click on the cell to select it and place the cursor in the cell for editing.

2) Reposition the cursor to where you want to start entering the new data in the cell.

Alternatively:

1) Single-click to select the cell.

2) Move the cursor to the Input Line on the Formula Bar (Figure 90 on page 114) and click at 
the position where you want to start entering the new data in the cell.

When you have finished, click away from the cell to deselect it and your editing changes are saved.

Formatting data

Note

All the settings discussed in this section can also be set as a part of the cell style. 
See the Calc Guide Chapter 4 Using Styles and Templates in Calc for more 
information.

Multiple lines of text

Multiple lines of text can be entered into a single cell using automatic wrapping or manual line 
breaks. Each method is useful for different situations.

Automatic wrapping

To automatically wrap multiple lines of text in a cell:

1) Right-click on the cell and select Format Cells from the context menu, or go to Format > 

Cells on the main menu bar, or press Ctrl+1 to open the Format Cells dialog.

2) Click on the Alignment tab (Figure 114).

3) Under Properties, select Wrap text automatically and click OK.
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Figure 114: Format Cells dialog – Alignment page

Manual line breaks

To insert a manual line break while typing in a cell, press Ctrl+Enter. This method does not work 
with the cursor in the input line. When editing text, double-click the cell, then reposition the cursor 
to where you want the line break.

When a manual line break is entered, the cell width does not change and your text may still overlap 
the end of the cell. You have to change the cell width manually or reposition your line break so that 
your text does not overlap the end of the cell.

Shrinking text to fit the cell

The font size of the data in a cell can automatically adjust to fit inside cell borders. To do this, 
select the Shrink to fit cell size option under Properties in the Format Cells dialog (Figure 114).

Formatting numbers

Several different number formats can be applied to cells by using icons on the Formatting toolbar 
(highlighted in Figure 115). Select the cell, then click the relevant icon to change the number 
format.

Figure 115: Number icons on Formatting toolbar

For more control or to select other number formats, use the Numbers page of the Format Cells 
dialog (Figure 107 on page 131):

• Apply any of the data types in the Category list to the data.

• Control the number of decimal places and leading zeros in Options.
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• Enter a custom format code.

• The Language setting controls the local settings for the different formats such as the date 
format and currency symbol.

Formatting font

To quickly select a font and format it for use in a cell:

1) Select the cell.

2) Click the small triangle on the right of the Font Name box on the Formatting toolbar 
(highlighted in Figure 116) and select a font from the drop-down list.

3) Click on the small triangle on the right of the Font Size on the Formatting toolbar and select 
a font size from the drop down list.

Figure 116: Font Name and Size on Formatting toolbar

4) To change the character format, click on the Bold, Italic, or Underline icons.

5) To change the paragraph alignment of the font, click on one of the four alignment icons 

(Left, Center, Right, Justified) .

6) To change the font color, click the arrow next to the Font Color icon  to display the color 
palette, then select the desired color.

To specify the language used in the cell, open the Font page on the Format Cells dialog. Changing 
language in a cell allows different languages to exist within the same document. Use the Font 
Effects tab on the Format Cells dialog to set other font characteristics. See the Calc Guide Chapter 
4 Using Styles and Templates in Calc for more information.

Formatting cell borders

To format the borders of a cell or a group of selected cells, click on the Borders icon  on the 
Formatting toolbar, and select one of the border options displayed in the palette.

To format the line style and line color for the borders of a cell, click the small arrows next to the 

Line Style  and Line Color (Border Color)  icons on the Formatting toolbar. A line style 
palette or a border color palette is displayed.

For more control, including the spacing between cell borders and any data in the cell, use the 
Borders page of the Format Cells dialog (Figure 107 on page 131), where you can also define a 
shadow style. See the Calc Guide Chapter 4 Using Styles and Templates in Calc for more 
information.

Note

Cell border properties apply only to the selected cells and can be changed only if 
you are editing those cells. For example, if cell C3 has a top border, that border 
can be removed only by selecting C3. It cannot be removed in C2 although it 
appears to be the bottom border for cell C2.

Formatting cell background

To format the background color for a cell or a group of cells, click the small arrow next to the 

Background Color icon  on the Formatting toolbar. A color palette, similar to the Font Color 
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palette, is displayed. You can also use the Background tab of the Format Cells dialog (Figure 107 
on page 131). See the Calc Guide Chapter 4 Using Styles and Templates in Calc for more 
information.

AutoFormat of cells

Using AutoFormat

You can use Calc’s AutoFormat feature to format a group of cells quickly and easily.

1) Select the cells in at least three columns and rows, including column and row headers, that 
you want to format.

2) Go to Format > AutoFormat on the main menu bar to open the AutoFormat dialog 
(Figure 117).

3) Select the type of format and format color from the list.

4) If necessary, click More to open Formatting if Formatting is not visible.

5) Select the formatting properties to be included in the AutoFormat function.

6) Click OK.

Figure 117: AutoFormat dialog

Defining a new AutoFormat

You can define a new AutoFormat so that it becomes available for use in all spreadsheets.

1) Format the data type, font, font size, cell borders, cell background and so on for a group of 
cells.

2) Go to Edit > Select All on the main menu bar to select the whole spreadsheet.

3) Go to Format > AutoFormat to open the AutoFormat dialog and the Add button is now 
active.

4) Click Add.

5) In the Name box of the Add AutoFormat dialog that opens, type a meaningful name for the 
new format.

6) Click OK to save. The new AutoFormat is now available in the Format list in the 
AutoFormat dialog.
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Using themes

Calc comes with a predefined set of formatting themes that you can apply to spreadsheets. It is not 
possible to add themes to Calc and they cannot be modified. However, you can modify their styles 
after you apply them to a spreadsheet and the modified styles are only available for use for that 
spreadsheet when you save the spreadsheet.

To apply a theme to a spreadsheet:

1) Click the Choose Themes icon  in the Tools toolbar. If this toolbar is not visible, go to 
View > Toolbars on the main menu bar and select Tools and the Theme Selection dialog 
(Figure 118) opens. This dialog lists the available themes for the whole spreadsheet.

2) Select the theme that you want to apply. As soon as you select a theme, the theme styles 
are applied to the spreadsheet and are immediately visible.

3) Click OK.

4) If you wish, you can now open the Styles and Formatting window to modify specific styles. 
These modifications do not modify the theme; they only change the appearance of the style 
in the specific spreadsheet you are creating.

Figure 118: Theme Selection dialog

Using conditional formatting

You can set up cell formats to change depending on conditions that you specify. For example, in a 
table of numbers, you can show all the values above the average in green and all those below the 
average in red.

Conditional formatting depends upon the use of styles and the AutoCalculate feature must be 
enabled. Go to Tools > Cell Contents > AutoCalculate on the main menu bar to enable this 
feature. See the Calc Guide Chapter 2 Entering, Editing, and Formatting Data for more information.
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Hiding and showing data

In Calc you can hide elements so that they are neither visible on a computer display nor printed 
when a spreadsheet is printed. However, hidden elements can still be selected for copying if you 
select the elements around them. For example, if column B is hidden, it is copied when you select 
columns A and C.

For more information on how to hide and show data, including how to use outline groups and 
filtering, see the Calc Guide Chapter 2 Entering, Editing, and Formatting Data.

Hiding data

To hide sheets, rows, and columns:

1) Select the sheet, row or column you want to hide.

2) Go to Format on the main menu bar and select Sheet, Row or Column.

3) Select Hide from the menu and the sheet, row or column can no longer viewed or printed.

4) Alternatively, right-click on the sheet tab, row header or column header and select Hide 
from the context menu.

To hide and protect data in selected cells:

1) Go to Tools > Protect Document and select Sheet from the menu options. The Protect 

Sheet dialog dialog will open (Figure 119).

2) Select Protect this sheet and the contents of protected cells.

3) Create a password and then confirm the password.

4) Select or deselect the user selection options for cells.

5) Click OK.

6) Select the cells you want to hide.

7) Go to Format > Cells on the main menu bar, or right-click and select Format Cells from 
the context menu, or use the keyboard shortcut Ctrl+1 to open the Format Cells dialog.

8) Click the Cell Protection tab (Figure 120) and select an option to hide the cells.

9) Click OK.

Note

When data in cells are hidden, it is only the data contained in the cells that is 
hidden and the protected cells cannot be modified. The blank cells remain visible 
in the spreadsheet.

Figure 119: Protect Sheet dialog
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Figure 120: Cell Protection page in Format Cells dialog

Showing data

To show hidden sheets, rows, and columns:

1) Select the sheets, rows or columns each side of the hidden sheet, row or column.

2) Go to Format on the main menu bar and select Sheet, Row or Column.

3) Select Show from the menu and the sheet, row or column will be displayed and can be 
printed.

4) Alternatively, right-click on the sheet tabs, row headers or column headers and select 
Show from the context menu.

To show hidden data in cells:

1) Go to Tools > Protect Document and select Sheet from the menu options.

2) Enter the password to unprotect the sheet and click OK.

3) Go to Format > Cells on the main menu bar, or right-click and select Format Cells from 
the context menu, or use the keyboard shortcut Ctrl+1 to open the Format Cells dialog.

4) Click the Cell Protection tab (Figure 120) and deselect the hide options for the cells.

5) Click OK.

Sorting records

Sorting within Calc arranges the cells in a sheet using the sort criteria that you specify. Several 
criteria can be used and a sort applies each criteria consecutively. Sorts are useful when you are 
searching for a particular item and become even more useful after you have filtered data.

Also, sorting is useful when you add new information to your spreadsheet. When a spreadsheet is 
long, it is usually easier to add new information at the bottom of the sheet, rather than adding rows 
in their correct place. After you have added information, you then carry out a sort to update the 
spreadsheet.

For more information on how to sort records and the sorting options available, see the Calc Guide 
Chapter 2 Entering, Editing, and Formatting Data.
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Figure 121: Sort Criteria dialog

To sort cells in your spreadsheet:

1) Select the cells to be sorted.

2) Go to Data > Sort on the main menu bar to open the Sort dialog (Figure 121).

3) Select the sort criteria from the drop down lists. The selected lists are populated from the 
selected cells.

4) Select either ascending order (A-Z, 1-9) or descending order (Z-A, 9-1).

5) Click OK and the sort is carried out on your spreadsheet.

Using formulas and functions

You may need more than numbers and text on your spreadsheet. Often the contents of one cell 
depend on the contents of other cells. Formulas are equations that use numbers and variables to 
produce a result. Variables are placed in cells to hold data required equations.

A function is a predefined calculation entered in a cell to help you analyze or manipulate data. All 
you have to do is enter the arguments and the calculation is automatically made for you. Functions 
help you create the formulas required to get the results that you are looking for.

See the Calc Guide Chapter 7 Using Formulas and Functions for more information.

Analyzing data

Calc includes several tools to help you analyze the information in your spreadsheets, ranging from 
features for copying and reusing data, to creating subtotals automatically, to varying information to 
help you find the answers you need. These tools are divided between the Tools and Data menus.

One of the most useful of these tools is the PivotTable, which is used for combining, comparing, 
and analyzing large amounts of data easily. Using the PivotTable, you can view different 
summaries of the source data, display the details of areas of interest, and create reports, whether 
you are a beginner, an intermediate or advanced user.

See the Calc Guide Chapter 8 Using Pivot Tables and Chapter 9 Data Analysis for more 
information on pivot tables and other tools available in Calc to analyze your data.
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Printing

Printing from Calc is much the same as printing from other LibreOffice components (see Chapter 
10 Printing, Exporting, and Emailing in this guide). However, some details for printing in Calc are 
different, especially regarding preparation for printing.

Print ranges

Print ranges have several uses, including printing only a specific part of the data or printing 
selected rows or columns on every page. For more information about using print ranges, see the 
Calc Guide Chapter 6 Printing, Exporting, and E-mailing.

Defining a print range

To define a new print range or modify an existing print range:

1) Select the range of cells to be included in the print range.

2) Go to Format > Print Ranges > Define on the main menu bar. Page break lines are 
displayed on screen.

3) To check the print range, go to File > Page Preview on the main menu bar or click on the 

Page Preview icon . LibreOffice will display the cells in the print range.

Adding to a print range

After defining a print range, you can add more cells to it by creating another print range. This 
allows multiple, separate areas of the same sheet to be printed while not printing the whole sheet. 

1) After defining a print range, select an extra range of cells for adding to the print range.

2) Go to Format > Print Ranges > Add on the main menu bar to add the extra cells to the 
print range. The page break lines are no longer displayed on the screen.

3) To check the print ranges, go to File > Page Preview on the main menu bar or click on the 

Page Preview icon . LibreOffice will display the print ranges as separate pages.

Note
The additional print range will print as a separate page, even if both ranges are on 
the same sheet.

Removing a print range

It may become necessary to remove a defined print range, for example, if the whole sheet needs to 
be printed later.

To remove all the defined print ranges, go to Format > Print Ranges > Remove on the main menu 
bar. After the print ranges have been removed, the default page break lines will appear on the 
screen.

Editing a print range

At any time, you can directly edit the print range, for example to remove or resize part of the print 
range. Go to Format > Print Ranges > Edit on the main menu bar to open the Edit Print Ranges 
dialog where you can define the print range.
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Printing options

To select the printing options of  page order, details, and scale to be used when printing a 
spreadsheet:

1) Go to Format > Page on the main menu to open the Page Style dialog ().

2) Select the Sheet tab and make your selections from the available options.

3) Click OK.

For more information on printing options, see the Calc Guide Chapter 6 Printing, Exporting, and 
E-mailing.

Repeat printing of rows or columns

If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat on each 
printed page. For example, if the top two rows of the sheet as well as column A need to be printed 
on all pages, do the following:

1) Go to Format > Print Ranges > Edit. on the main menu bar to open the Edit Print 

Ranges dialog (Figure 122).

2) Type the row identifiers in the Rows to repeat box. For example, to repeat rows 1 and 2, 
type $1:$2. This automatically changes Rows to repeat  from, - none -  to - user defined -.

3) Type the column identifiers in the Columns to repeat box. For example, to repeat column A, 
type $A. In the Columns to repeat list, - none - changes to - user defined -.

4) Click OK.

Figure 122: Edit Print Ranges dialog

For more information on editing print ranges, see the Calc Guide Chapter 6 Printing, Exporting, 
and E-mailing.

Page breaks

While defining a print range can be a powerful tool, it may sometimes be necessary to manually 
adjust the Calc printout manually using a manual or page break. A page break helps to ensure that 
your data prints properly according to your page size and page orientation. You can insert a 
horizontal page break above or a vertical page break to the left of the active cell.

For more information on manual breaks, see the Calc Guide Chapter 6 Printing, Exporting, and 
E-mailing.

Inserting a break

To insert a page break:

1) Navigate to the cell where the page break will begin.

2) Go to Insert > Page Break on the main menu bar.
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3) Select Row Break to create a page break above the selected cell.

4) Select Column Break to create a page break to the left of the selected cell.

Deleting a page break

To remove a page break:

1) Navigate to a cell that is next to the break you want to remove.

2) Go to Edit > Delete Page Break on the main menu bar.

3) Select Row Break or Column Break depending on your need and break is removed.

Note
Multiple manual row and column breaks can exist on the same page. When you 
want to remove them, you have to remove each break individually.

Headers and footers

Headers and footers are predefined pieces of text that are printed at the top or bottom of a printed 
page when a spreadsheet is printed. Headers and footers are set and defined using the same 
method. For more information on setting and defining headers and footers, see the Calc Guide 
Chapter 6 Printing, Exporting, and E-mailing.

Headers and footers are also assigned to a page style. You can define more than one page style 
for a spreadsheet and assign different page styles to different sheets within a spreadsheet. For 
more information on page styles, see the Calc Guide Chapter 4 Using Styles and Templates.

Figure 123: Header dialog

Setting a header or footer

To set a header or footer:

1) Navigate to the sheet that you want to set the header or footer for.

2) Go to Format > Page on the main menu bar to open the Page Style dialog (Figure 123).

3) On the Page Style dialog, select Header or Footer tab.

4) Select the Header on or Footer on option.
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5) Select Same content left/right option if you want the same header or footer to appear on 
all the printed pages.

6) Set the margins, spacing, and height for the header or footer. You can also select AutoFit 

height box to automatically adjust the height of the header or footer.

7) To change the appearance of the header or footer, click on More to open the borders and 
background dialog.

8) To set the contents, for example page number, date and so on, that appears in the header 
or footer, click on Edit to open the style dialog.
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